Bug #874

view patchers don't get their context from the filename anymore

Added by Pascal Baltazar almost 8 years ago. Updated over 7 years ago.

Status:ClosedStart date:2011-07-23
Priority:NormalDue date:
Assignee:Théo de la Hogue% Done:

0%

Category:-Spent time:-
Target version:MVC for 0.6
Branch: OS:

Description

previously, when a patcher was named with .view.maxpat, the context of its hub was automatically set to view
this doesn't work anymore

History

#1 Updated by Théo de la Hogue almost 8 years ago

  • Status changed from New to Resolved

Actually this is not a bug because the lines are just commented.

During the workshop Tom's made some patchers and used the ".view" or ".model"
for any reasons to name a patch. If he was agree with the naming convention
he found (and me too) that is always dangerous and very unclear to have 2 ways
to set the context info.

So now the ".model" and ".view" are parsed in the filename to edit the class of
the patcher but it's not used to set it anymore (you have to use the @context attribute)

Of course this is not definitive and it is easy to go back (uncomment lines 1472 to 1489 in ModularForMax.cpp)

sorry for not having focused your attention on this important change

#2 Updated by Théo de la Hogue over 7 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF