Bug #839

jcom.init doesn't work when in a subpatcher

Added by Pascal Baltazar about 8 years ago. Updated about 8 years ago.

Status:ClosedStart date:2011-07-17
Priority:NormalDue date:
Assignee:Théo de la Hogue% Done:

0%

Category:-Spent time:-
Target version:MVC for 0.6
Branch: OS:

Description

what else to say ?

I noticed that in a view patcher, maybe this is important ?

History

#1 Updated by Pascal Baltazar about 8 years ago

this can be noticed also in jcom.init.maxhelp

#2 Updated by Théo de la Hogue about 8 years ago

  • Status changed from New to Resolved

Actually it was not a bug : the jcom.init needs a hub in the patcher where it is.
It don't need argument anymore except if we want to bind on a submodel from the root model part
(but it is not possible to bind on the root initialisation from a submodel)

is it good ?

#3 Updated by Pascal Baltazar about 8 years ago

thanks Théo, this is great !

though, I think it would be nice to have jcom.init working in a subpatcher (without a hub) as if it were in the main patch... sometimes you want to have subpatchers for the sake of patching clarity and don't want them to be submodels.
of course, this can be done with a send (see below), but maybe it is a bit confusing, because I guess the most common case will be not to have submodels (???)

what do you think ? and is this possible at all ?


----------begin_max5_patcher----------
845.3ocyWszbaBCD9L9WAC8pqGD3WzSs+I5kLY7HPqsUJHwHDNoIS9uWg3gQ
1PhrcZZOXr8tq1GeZ2kceYhiWL+Invy8at24537xDGGMoJBNM+2wKC+TRJtP
KlGCdjG+f2zZVR3Iol7CI7rYTFU1xgUlwKkofTerfFpThVZkF9ZPTqna4LIC
mAZV+DDDLC2xqVGxemC0Nom2T0G266czB5yZlH+Y9Mjywxj8T1tMBHQVevf0
JttHzR8W995uhl42oJkCSYs9Kph1qSlT8X5sgLEtewey3Hi+.Hy5AQleHn3T
uAB7HKh64n9w8pOg3N2snLV6P1G3qrIk3RuyiPVckanGPzDvMQrxpzT3.HJn
bl1vSanezZKzFHZd0yP+nZiFdzbJbbWJO4W.om4b7Hv1KQG7bfcTds3FOLkj
xxEPAvjXYii22t3xT4lAyjLYuEm.id1AyOc71InDNqxGLNYE4VqcmKZgNBWz
2s0Rvv4CbXImmFiEGnEz3Tv3ZPkhhYzLrDjzZ+Ivu6bzrbAkIMzEvvJcruHQ
vSSMTUMmCCvg.GnIviThbuVWGQKi1n8RaLJdLn+VEQlERhSZfLPsDpGmd0Sy
6ehwuqFtOa2MxnsaFqrCsVWwEFMRKmAp8Zoqa8T+ioe7HoNKvUUNPdG7zeX7
Lzd77Z.rkHqALzmIfw3xqCuB9KgWgg+eBWmNDz3CBcJRgtkJ0o2T0ZMXFt3l
.yisuSorw5DpMdE+gQ4BdoHoMnZ.EWS+f.ERJq6cY20klchb6oDh46NzWiTR
NWkP23dt2aUVwk50yszqC+.85FhJ2udFlB7AfrQYE0s7FrTJnwkx5qEiYZF+
02u4q+UiwDiSaFTpSAcm8ZGYvhIQ5wdxQL3BGXMCJJv6fylXs+P5UDS3obQS
GZcYQ+GcCQFuSKWv6J3fux1ncYv0sQTmE1IvDJXLnSq60Nt3RTzR+0ciKFtz
e054U+ZkuhC5pWrJPuWUXvrEu05EsqAtUveFXaTWSmjcpBmiAw8ebKin6Luu
L186Ip.SQ0MiSftsopJuS3k0HWfsavF9OXA145UChp6YirYMNsDlskqAxSar
0.mm0PKvn+pMcyNuS1vcwN6t0ZWJxBWpZM5q1mT+40I+AzW5FSI
-----------end_max5_patcher-----------

#4 Updated by Pascal Baltazar about 8 years ago

  • Status changed from Resolved to Assigned
  • Priority changed from High to Normal

#5 Updated by Théo de la Hogue about 8 years ago

What is the meaning of "Assigned" ?
because now it works with your example patch

on my computer this bug seems closed, isn't it ?

#6 Updated by Pascal Baltazar about 8 years ago

  • Status changed from Assigned to Closed

yes, you're right, it works, sorry about that... maybe I missed something..

(BTW, assigned means it is assigned to someone - here it was you)

Also available in: Atom PDF