Bug #614

jcom.ui menu : "Store as next" does not pop up dialog window

Added by Julien Rabin almost 9 years ago. Updated about 8 years ago.

Status:ClosedStart date:2010-09-23
Priority:NormalDue date:2010-09-30
Assignee:Diemo Schwarz% Done:

100%

Category:-Estimated time:1.00 hour
Target version:-Spent time:1.00 hour
Branch:master OS:

Description

When selecting "Store as next" from jcom.ui menu, no dialog window is opened to set a name for the preset and a preset is created with the name "Store as next". Selecting this preset stores a new preset named "Store as next". And so one.

Expected behaviour: select "Store as next" pop a window up to set a name for the preset, just like when sending to jcom.hub '/preset/storenext'.

(sending '/preset/storenext' works fine)

History

#1 Updated by Diemo Schwarz almost 9 years ago

  • Due date set to 2010-09-30
  • Status changed from New to Assigned
  • Assignee set to Diemo Schwarz
  • % Done changed from 0 to 10
  • Estimated time set to 1.00

Bug tracked down, but not fixed yet

The reason for this bug is because I extended (with everyone's consent) the '/preset/storenext' message by an optional parameter to give the name right away.

Unfortunately, jcom.ui seems to send the menu entry's name as argument to the message, so no dialog box appears.

Proposed fix: don't send this argument.

#2 Updated by Diemo Schwarz almost 9 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 10 to 100

fixed with commit 9bcd0a6b781187388b53

#3 Updated by Nils Peters about 8 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF