Bug #495

Not able to set @ramp/function as attribute argument to jcom.parameter

Added by Trond Lossius almost 10 years ago. Updated over 8 years ago.

Status:ClosedStart date:2010-04-22
Priority:HighDue date:
Assignee:Trond Lossius% Done:

100%

Category:-Spent time:-
Target version:0.5.2
Branch:master OS:OSX

Description

On Daniels laptop using Max 5.1.3 and standard Jamoma installer

History

#1 Updated by Nils Peters over 9 years ago

Hi Trond,

I think line 257-258 of jcom.parameter.cpp are the reason for this bug:

if (x->attr_rampfunction == _sym_nothing && x->attr_ramp != _sym_none)
            object_attr_setsym(x, gensym("ramp/function"), jps_linear);
else
 object_attr_setsym(x, gensym("ramp/function"), _sym_none);

best,

Nils

#2 Updated by Trond Lossius over 9 years ago

  • Branch changed from 0.5-maintenance to master
  • OS set to OSX

Confirmed on my own laptop as well, as illustrated by this simple patch:


----------begin_max5_patcher----------
244.3occP1raCCBC.9L7TXw4rr7ytrcpOE6xTUEk3tRUhIBbVyVUe2W.R5Ns
CXK9L19SbSJTGcyXPAuAe.BwMoPjPQfX8tPMnmM85P5YJBu5NdQUjKw3LmvW
LtgxQsWOfL5AFCLri+dDgNzXGz8vtkZiO24segPvbF6l5WdXldZhLr0QfwEr
DtM8QMaNaoOO3QCmkrtpprp.ZZRoWZaho5WKqf8qMQSCtItG4jusqTaWRyE0
epca7mbDGr+fwJ0w4kw4titmWoRUrddriQOFPh0Qm+W41BO5JtOZ4CJYx6nu
SSZ0eVaoMoqir6RYL.6k2k+BKD.a+C
-----------end_max5_patcher-----------

#3 Updated by Trond Lossius over 8 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Applied in changeset commit:f2cc4b48636738dc4451164bb0f1533ec4e40926.

Also available in: Atom PDF