Bug #361

crash with /view/size:/value/inc

Added by Nils Peters over 8 years ago. Updated almost 6 years ago.

Status:ClosedStart date:2009-11-22
Priority:HighDue date:
Assignee:Trond Lossius% Done:

0%

Category:-Spent time:-
Target version:core-maintenance-sprint
Branch: OS:

Description

I guess this is related to the @readonly attribute.

when sending a /view/size:/value/inc message to a module, I get the following crash.

Process: MaxMSP [53716]
Path: /Applications/Max5/MaxMSP.app/Contents/MacOS/MaxMSP
Identifier: com.cycling74.MaxMSP
Version: 5.1.0b9 (41021) (5.1.0b9)
Code Type: X86 (Native)
Parent Process: launchd [680]

Date/Time: 2009-11-22 14:43:44.142 -0500
OS Version: Mac OS X 10.6.2 (10C540)
Report Version: 6

Interval Since Last Report: 441543 sec
Crashes Since Last Report: 33
Per-App Interval Since Last Report: 186090 sec
Per-App Crashes Since Last Report: 12
Anonymous UUID: 931024BF-AD53-44ED-AD42-A80B5B678FEB

Exception Type: EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x00000000000002e0
Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Thread 0 Crashed: Dispatch queue: com.apple.main-thread
0 libSystem.B.dylib 0x98e6fa90 strlen + 16
1 libSystem.B.dylib 0x98e7a400 __vfprintf + 6630
2 libSystem.B.dylib 0x98e9990a vsnprintf + 395
3 com.cycling74.MaxMSP 0x0002bd79 vsnprintf_zero + 45
4 com.cycling74.MaxMSP 0x000282c7 error + 49
5 com.cycling74.MaxAPI 0x00f9723c error + 91
6 org.jamoma.jcom.parameter 0x00de1983 param_inc(_param*, symbol*, long, atom*) + 407 (jcom.parameter.cpp:1215)
7 com.cycling74.MaxMSP 0x000b6266 object_method_typedfun + 134
8 com.cycling74.MaxMSP 0x000b631f object_method_typed + 127
9 com.cycling74.MaxAPI 0x00fa55e4 object_method_typed + 59
10 org.jamoma.jcom.hub 0x1c6e58fc hub_symbol(_hub*, symbol*, long, atom*) + 394 (jcom.hub.cpp:1201)
11 com.cycling74.MaxMSP 0x000b6266 object_method_typedfun + 134
12 com.cycling74.MaxMSP 0x000b631f object_method_typed + 127
13 com.cycling74.MaxAPI 0x00fa55e4 object_method_typed + 59
14 org.jamoma.jcom.hub 0x1c6e5b5c hub_receive_callback(void*, symbol*, long, atom*) + 372 (jcom.hub.cpp:1315)
15 com.cycling74.MaxMSP 0x000b8fed object_method + 901
16 com.cycling74.MaxMSP 0x0005b006 linklist_methodall + 198
17 com.cycling74.MaxAPI 0x00fa026f linklist_methodall + 150
18 org.jamoma.JamomaModular 0x0392bd3c receivemaster_dispatch(_jcom_receivemaster*, symbol*, symbol*, long, atom*) + 96
19 com.cycling74.MaxMSP 0x000b8fed object_method + 901
20 com.cycling74.MaxAPI 0x00fa5587 object_method + 156
21 org.jamoma.JamomaModular 0x0392c0c6 send_list(_send*, symbol*, long, atom*) + 72
22 com.cycling74.MaxMSP 0x0001be30 typedmess_fun + 782
23 com.cycling74.MaxMSP 0x0006327b outlet_anything + 727
24 com.cycling74.MaxMSP 0x0001be30 typedmess_fun + 782
25 com.cycling74.MaxMSP 0x0001c361 typedmess + 83
26 com.cycling74.MaxMSP 0x0001be30 typedmess_fun + 782
27 com.cycling74.MaxMSP 0x0006327b outlet_anything + 727
28 com.cycling74.MaxMSP 0x0001be30 typedmess_fun + 782
29 com.cycling74.MaxMSP 0x0001c361 typedmess + 83
30 com.cycling74.MaxMSP 0x0001c9cd aeval + 893
31 com.cycling74.MaxMSP 0x00007f04 atombuf_eval + 152
32 com.cycling74.MaxAPI 0x00fa42e7 atombuf_eval + 60
33 com.cycling74.message 0x1a54c0ad jmessage_atombuf_eval + 429
34 com.cycling74.message 0x1a54c409 jmessage_bang + 129
35 com.cycling74.MaxMSP 0x00064586 outlet_bang + 674
36 com.cycling74.MaxMSP 0x0001be30 typedmess_fun + 782
37 com.cycling74.MaxMSP 0x0006327b outlet_anything + 727
38 com.cycling74.MaxMSP 0x0001be30 typedmess_fun + 782
39 com.cycling74.MaxMSP 0x0001c361 typedmess + 83
40 com.cycling74.MaxMSP 0x0001be30 typedmess_fun + 782
41 com.cycling74.MaxMSP 0x0006327b outlet_anything + 727
42 com.cycling74.MaxAPI 0x00f97a8d outlet_anything + 60
43 com.cycling74.textbutton 0x031cc3b4 jtextbutton_outlet_symbol + 134
44 com.cycling74.textbutton 0x031cc595 jtextbutton_do_outlet + 105
45 com.cycling74.textbutton 0x031cc682 jtextbutton_int + 86
46 com.cycling74.textbutton 0x031cd927 jtextbutton_mouseup + 299
47 com.cycling74.MaxMSP 0x000b8fed object_method + 901
48 com.cycling74.MaxMSP 0x00109b76 BoxComponent::sendMouseMessage(juce::MouseEvent const&, symbol*, double, double) + 414
49 com.cycling74.MaxMSP 0x0010a070 BoxComponent::mouseUp(juce::MouseEvent const&) + 462
50 com.cycling74.MaxMSP 0x002f0e1b juce::Component::internalMouseUp(int, int, int, long long) + 541
51 com.cycling74.MaxMSP 0x0038a23e juce::ComponentPeer::handleMouseUp(int, int, int, long long) + 546
52 com.cycling74.MaxMSP 0x002cbf47 juce::juce_dispatchNextMessageOnSystemQueue(bool, bool) + 463
53 com.cycling74.MaxMSP 0x002d5a87 juce::MessageManager::dispatchNextMessage(bool, bool*, bool) + 79
54 com.cycling74.MaxMSP 0x002d5b46 juce::MessageManager::runDispatchLoop() + 42
55 com.cycling74.MaxMSP 0x002d44a1 juce::JUCEApplication::main(juce::String&, juce::JUCEApplication*) + 605
56 com.cycling74.MaxMSP 0x002d457b juce::JUCEApplication::main(int, char**, juce::JUCEApplication*) + 125
57 com.cycling74.MaxMSP 0x001de666 main + 76
58 com.cycling74.MaxMSP 0x00005526 _start + 216
59 com.cycling74.MaxMSP 0x0000544d start + 41


Related issues

Related to Modular - Bug #157: readonly not properly implemented in jcom.parameter Rejected 2009-05-29

History

#1 Updated by Tim Place over 8 years ago

  • Status changed from New to Assigned
  • Assignee set to Tim Place
  • Priority changed from Normal to High

#2 Updated by Nils Peters over 6 years ago

  • Target version changed from 0.5.1 to 0.5.5

#3 Updated by Trond Lossius about 6 years ago

  • Assignee changed from Tim Place to Trond Lossius

Assigning to me

#4 Updated by Trond Lossius about 6 years ago

  • Target version changed from 0.5.5 to core-maintenance-sprint

#5 Updated by Nils Peters almost 6 years ago

  • Status changed from Assigned to Resolved

I can't reproduce this crash. I get a proper error message instead:

view/size parameter (in the jmod.input~ module) is an inappropriate type for the 'inc' message.

#6 Updated by Trond Lossius almost 6 years ago

  • Status changed from Resolved to Closed

Neither can I reproduce. I'm closing the issue.

Also available in: Atom PDF