Bug #343

ramping of /preset/interpolate doesn't work

Added by Nils Peters almost 11 years ago. Updated over 7 years ago.

Status:ClosedStart date:2009-10-26
Priority:HighDue date:
Assignee:-% Done:

0%

Category:-Spent time:-
Target version:0.5.5
Branch: OS:

Description

bug or feature request - whatever.

would be very useful if the interpolation between modules presets would work with a ramp command, e.g.

/preset/interpolate preset1 preset2 0.5 ramp 2000

see attached patch:

----------begin_max5_patcher----------
657.3oc2VssiaBCD8YxWgEpR8kTVrABj9TqT+B5qcqpLfCwYAajsQaZWs+60
1bIjkr6lMWVU0GBAOdlwybNGM3Gl43lx2RjtfOC9Avw4gYNNVSFCNcqcbqva
yJwRqatY7pJBS4NucOEYqxZWslJA4bh7iLE3dt3tdOXMUTVIQYCG1YbEmojz
+Pr1Pd967k2n5ct2JM2dB7zMeBE1m1Uhhz151WG9nGPOevOGcLLbk8Xb+pfh
K6CuFqxVSYE+RPxTs4YQbhI9kg1rDYSFx2jMSHONal4w7KALYfG40AeBtd3S
zRa7QKtD3ypRttYNeL.MECfCZjV+T+tlz1AlSEq4DfaJlU3dZv.BZkIAsfwH
TnKjzhLdIWzi8Av3EgwFrO1eYhen4s.DLZwxNp3D.uJhThKHSDW2TKHRh5FJ
SQD07Rrh.t086zB.5afDP1ZLiQJk.3stGzNRa+CvCRJn2Bo.mRJIOKmbdzPT
KYrHvJJS9+gG78h.BbUsVb46eUnj3KNkDFaGfFYdFhheMJIAp4jHKQDihBWN
9sSkRvUozJNipzGyKMbYezIXJ5LLDwxkLEVQ4rQM6tApnoy.lhny69M3xAkz
VULJHrMg9C+cRPAibutQlHN2n+zjWMWRMMDZDdA9htUWQ2Bj0D7cD8ZANm1n
ko9dm+f5CH.Ct7yDZAP+k1gB1Z4z+DUp8DHuEczAZR3Qqi59jZ7KKjF1Z.U1
Twy8jMBO8HmlZOcOTiGt3AVTzc8NW61Gi.DhRlTOivOaFbKormdwQaFM12GT
k7FQVe82AIfcsXNQpnLKrLxmf87YMMOmvFemmJZdMWOesqDdFB9Xqn3inhfu
qUTx+bUj4ZUuZIk7tVRAGQEEdFUjdwiy9K.DTDgT
-----------end_max5_patcher-----------


Related issues

Related to Modular - Bug #582: ramping for jcom.parameter @type array with a mixed array... Rejected 2010-08-26
Related to Modular - Feature Request #103: /preset/interpolate between preset ids Closed 2009-05-27
Related to Modular - Feature Request #1187: Change parameter names for preset/cue intepolation and mi... Rejected 2012-08-13

History

#1 Updated by Pascal Baltazar almost 11 years ago

IMHO, the problem is that this function should be better designed because here we mix the choice of the presets between which we want to interpolate and the interpolation value itself
maybe something like :
/preset/interpolate/source {name or number of source preset}
/preset/interpolate/destination {name or number of destination preset}
/preset/interpolate/ratio {float}
would be better ??

because, if we ramp the messages the way you ask, then what would happen if we did this ? :
/preset/interpolate "ITU 5 (3-2) channel surround" "ITU 7 (3-4) channel surround" 0.5
/preset/interpolate "Rig 2D 8 channels 1" "Rig 2D 8 channels 2" 0.5 ramp 2000
I guess the RampLib would try to interpolate between :
- "ITU 5 (3-2) channel surround" and "Rig 2D 8 channels 1"
and between
- "ITU 7 (3-4) channel surround" and "Rig 2D 8 channels 2"
and then process no interpolation between 0.5 and 0.5
which is not what you were thinking of, I guess... ??

BTW, my first thought was to do that in the same way than pattrstorage (i.e. 3.5 means half-interpolated between preset 3 and 4)
but I discovered in your patch the interest of keeping this separate the interpolation can be "extended" beyond the actual presets... (which pattrstorage doesn't do...) so I guess this is a good feature to keep...

maybe a good idea would to have a third function for straightforward interpolation, that would function with only one float, based on preset numbers ??? Maybe that's not a good idea, but I can see some applications of that with a simple mapper (of course Tim's jcom.snapshot is a zillion times more powerful... ;-)

#2 Updated by Nils Peters almost 11 years ago

BTW, my first thought was to do that in the same way than pattrstorage (i.e. 3.5 means half-interpolated between preset 3 and 4)
but I discovered in your patch the interest of keeping this separate the interpolation can be "extended" beyond the actual presets... (which pattrstorage doesn't do...) so I guess this is a good feature to keep...

Yes, I think this extrapolation feature is worth to keep - I don't know any other interpolation mechanism that can do this

#3 Updated by Tim Place almost 11 years ago

  • Target version changed from 0.5.1 to 0.5.2

#4 Updated by Nils Peters over 8 years ago

  • Target version changed from 0.5.2 to 0.5.5

#5 Updated by Théo de la Hogue over 7 years ago

should we move the target version to 0.6 ? in this case, this can be closed

#6 Updated by Trond Lossius over 7 years ago

  • Status changed from New to Closed

Yes. This is now officially a lost case for 0.5.7:..

Also available in: Atom PDF