Bug #299

jcom.out~ bug

Added by Pascal Baltazar about 10 years ago. Updated almost 10 years ago.

Status:ClosedStart date:2009-09-05
Priority:HighDue date:
Assignee:Pascal Baltazar% Done:

0%

Category:-Spent time:0.25 hour
Target version:-
Branch: OS:

Description

after a while, (and without any apparent reason...), the first outlet of the [jcom.out~ 4] object I'm using in the (tweaked and attached jmod.echo~) module goes to nan !!!

jalg.ZguapoEcho_.maxpat (36.8 KB) Pascal Baltazar, 2009-09-05 12:39 am

jmod.ZguapoEcho_.maxpat (41.6 KB) Pascal Baltazar, 2009-09-05 12:39 am

jmod.ZguapoEcho_.maxhelp (19.3 KB) Pascal Baltazar, 2009-09-05 12:39 am

History

#1 Updated by Pascal Baltazar about 10 years ago

this is on MacOS 10.5.8, Max 5.0.8 latest beta
the audio driver is mLan

#2 Updated by Tim Place about 10 years ago

  • Status changed from New to Assigned
  • Assignee set to Pascal Baltazar
  • Priority changed from Normal to High

Hi Pascal,

I can't reproduce with the given patcher:
- Does it happen with non-mLan audio drivers?
- How long is a while? 15 minutes and I can't find any problems...
- Are the specific steps or do you just play with this patcher and hope for the best?

I was imagining problems with jcom.in~ 1 being mismatched with jcom.out~ 4 (maybe the would both need to be set 4 and then you ignore the last 3 inputs). Maybe you could experiment there, but since I can't reproduce I can't see if that is a problem or not.

Cheers.

#3 Updated by Pascal Baltazar about 10 years ago

ho, sorry, maybe I wasn't clear enough in the bug report...

problems don't happen in this help patcher, but in a big patcher with a lot more processing... so it's difficult for me to attach it here (lots of dependencies, etc...)

I haven't tried with another audio driver, because the setup is quite complex to change (16in-16out to/from the mixing console...), but I'll do that as soon as I'm done with fixing bugs on this patch...

thanks for the follow-up...

#4 Updated by Nils Peters about 10 years ago

Hi Pascal,

I have a good feeling that the fix for issue 301 will also fix this issue.

#5 Updated by Tim Place about 10 years ago

I agree that 301 seems highly-correlated and may have solved this problem too.

#6 Updated by Tim Place almost 10 years ago

  • Status changed from Assigned to Closed

Also available in: Atom PDF