Bug #25

sur.ambi.adjust js bug

Added by Trond Lossius about 10 years ago. Updated about 10 years ago.

Status:ClosedStart date:2009-05-24
Priority:NormalDue date:
Assignee:Trond Lossius% Done:

100%

Category:-Spent time:0.60 hour
Target version:-
Branch: OS:

Description

There's an error message when instantiating jmod.sur.ambi.adjust~. Don't
know if it's critical, but reporting it :

• error: js: bad outlet index 0


Related issues

Related to Modular - Bug #360: jcom.jsui_multigain - old MIDI range (0 - 157) Closed 2009-11-16

History

#1 Updated by Trond Lossius about 10 years ago

  • % Done changed from 0 to 10

The error message is caused by jcom.jsui_multigain.js as the following patch illustrates:

----------begin_max5_patcher----------
216.3ocUPkkCCBBD8a3TX3aqQro1kqRSiAsTKFALBzXSSu6kMWZByLYdyx6M
7ABP0xIpBkbI4ZB.7AB.dHG.HlCPbxTSOQ4aC0oLLTZnvKxnfvoK3UbSul0R
Xh4NFH5lmLQa0HsQGnAeHKOM5KNgcgSkY4I2hiHLblnmp8zgm2yHUQEZhlIE
awY28jKq61gOhV2fznmWQQD8Aqmtp1FIO6eIaSmWPmhL1Z3VBieM3xzfYeKB
Mvg98.MzDBkZskxak7lyuve36KCmuObN2c9to9BgNmM4K7WXnTVu
-----------end_max5_patcher-----------

#2 Updated by Trond Lossius about 10 years ago

  • Status changed from New to Closed
  • % Done changed from 10 to 100
  • init() calls mode()
  • mode() again calls bang()
  • bang produce output

The init method hence cause output before the outlets have been properly instantiated.

Solved in commit 5464

Also available in: Atom PDF