Bug #238

jcom.ui default color values make modules turn black.

Added by Trond Lossius over 10 years ago. Updated over 10 years ago.

Status:ClosedStart date:2009-07-31
Priority:ImmediateDue date:
Assignee:Pascal Baltazar% Done:

100%

Category:-Spent time:0.20 hour
Target version:0.5
Branch: OS:

Description

To reproduce:

  1. Open jmod.output~.maxpat
  2. Send /preset/store 1 default, /preset/write to the hub, so that a new default preset file is saved
  3. Overwrite the existing preset file in the output~ folder.
  4. Close the module
  5. Reopen the folder
  6. jcom.ui border, toolbar, background and text have now turned black

This bug has been revealed after the fix of bug issue 49

When saving a module preset, colors get set as:

    <item name='view/color/border' type='msg_list' priority='0'>0</item>
    <item name='view/color/contentBackground' type='msg_list' priority='0'>0</item>
    <item name='view/color/toolbarBackground' type='msg_list' priority='0'>0</item>
    <item name='view/color/toolbarText' type='msg_list' priority='0'>0</item>

Now that initial values are actually properly output, this makes all colors go black.

History

#1 Updated by Tim Place over 10 years ago

  • Assignee changed from Tim Place to Pascal Baltazar

Assigning to Pascal since he is the one requiring this feature. I can't really do anything about it until we finish the discussion on the list (e.g. in terms of making the params not show up in presets, cuelists, mappers, etc.).

#2 Updated by Trond Lossius over 10 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Fixed in r5835 by adding a test for whether argc>1 before attempting to set the jcom.ui colors. The default value for these parameters is "0", and will now be filtered out (ignored).

Also available in: Atom PDF