Bug #223

crash when opening jcom.saturation.maxhelp twice

Added by Pascal Baltazar about 10 years ago. Updated about 10 years ago.

Status:ClosedStart date:2009-07-25
Priority:UrgentDue date:
Assignee:Tim Place% Done:

0%

Category:-Spent time:1.00 hour
Target version:0.5
Branch: OS:

Description

jcom.hub: preset file FAILED xml schema validation
jcom.hub: jmod.output~ module: preset.recall - invalid preset specified
jcom.hub: preset file FAILED xml schema validation
jcom.hub: jmod.input~ module: preset.recall - invalid preset specified
jcom.hub: preset file FAILED xml schema validation
jcom.hub: jmod.saturation~ module: preset.recall - invalid preset specified

History

#1 Updated by Pascal Baltazar about 10 years ago

  • Priority changed from Normal to Urgent
  • Target version set to 0.5

I get a reproducible crash when closing jcom.saturation.maxhelp for the second time

the few lines in the initial log are errors I had one of the times I tried this out

crash log excerpt below....

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x000000003f7ffff0
Crashed Thread: 0

Thread 0 Crashed:
0 com.cycling74.MaxMSP 0x00027c0a sysmem_ptrsize + 12
1 com.cycling74.MaxMSP 0x00027c62 sysmem_freeptr + 22
2 com.cycling74.MaxAPI 0x00e51083 sysmem_freeptr + 31
3 org.jamoma.jcom.hub 0x1e5125e1 hub_presets_clear(_hub*, symbol*, long, atom*) + 63
4 org.jamoma.jcom.hub 0x1e50f2d9 hub_free(_hub*) + 307
5 com.cycling74.MaxMSP 0x00029cf4 freeobject + 156
6 com.cycling74.MaxMSP 0x0014f4d1 jnewobj_free + 25
7 com.cycling74.MaxMSP 0x00029cf4 freeobject + 156
8 com.cycling74.MaxMSP 0x000aa2ad object_free + 27
9 com.cycling74.MaxMSP 0x00169102 jpatcher_free + 182
10 com.cycling74.MaxMSP 0x00029cf4 freeobject + 156
11 com.cycling74.MaxMSP 0x000aa2ad object_free + 27
12 com.cycling74.MaxMSP 0x0011d99b jbpatcher_setpatcher(_jbpatcher*, object*) + 117
13 com.cycling74.MaxMSP 0x0011e316 jbpatcher_free(_jbpatcher*) + 26
14 com.cycling74.MaxMSP 0x00029cf4 freeobject + 156
15 com.cycling74.MaxMSP 0x000aa2ad object_free + 27
16 com.cycling74.MaxMSP 0x00169102 jpatcher_free + 182
17 com.cycling74.MaxMSP 0x00029cf4 freeobject + 156
18 com.cycling74.MaxMSP 0x000aa2ad object_free + 27
19 com.cycling74.MaxMSP 0x000ad055 object_method + 901
20 com.cycling74.MaxMSP 0x0017f918 jwind_close + 624
21 com.cycling74.MaxMSP 0x000aa390 object_method_typedfun + 134
22 com.cycling74.MaxMSP 0x000aa449 object_method_typed + 127
23 com.cycling74.MaxMSP 0x0014d5a4 jmenu_process + 562
24 com.cycling74.MaxMSP 0x000d2414 interface_process + 24
25 com.cycling74.MaxMSP 0x0000f7bb app_eventhandler(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 169
26 com.apple.HIToolbox 0x9673111d DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 1181
27 com.apple.HIToolbox 0x9673055b SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 405
28 com.apple.HIToolbox 0x9674ceac SendEventToEventTarget + 52
29 com.apple.HIToolbox 0x967811c7 SendHICommandEvent(unsigned long, HICommand const*, unsigned long, unsigned long, unsigned char, OpaqueEventTargetRef*, OpaqueEventTargetRef*, OpaqueEventRef**) + 411
30 com.apple.HIToolbox 0x967a7939 SendMenuCommandWithContextAndModifiers + 59
31 com.apple.HIToolbox 0x967a78f4 SendMenuItemSelectedEvent + 134
32 com.apple.HIToolbox 0x9682bb23 HIMenuBar::HandleKeyboardEvent(OpaqueEventRef*) + 409
33 com.apple.HIToolbox 0x96731629 HIObject::EventHook(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 173
34 com.apple.HIToolbox 0x9673111d DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 1181
35 com.apple.HIToolbox 0x9673055b SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 405
36 com.apple.HIToolbox 0x967303c0 SendEventToEventTargetWithOptions + 58
37 com.apple.HIToolbox 0x9675f2e7 ToolboxEventDispatcherHandler(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 1815
38 com.apple.HIToolbox 0x967314d6 DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 2134
39 com.apple.HIToolbox 0x9673055b SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 405
40 com.apple.HIToolbox 0x9674ceac SendEventToEventTarget + 52
41 com.cycling74.MaxMSP 0x0029ad14 juce::juce_dispatchNextMessageOnSystemQueue(bool) + 580
42 com.cycling74.MaxMSP 0x002a470a juce::MessageManager::dispatchNextMessage(bool, bool*) + 68
43 com.cycling74.MaxMSP 0x002a47b4 juce::MessageManager::runDispatchLoop() + 34
44 com.cycling74.MaxMSP 0x002a30ff juce::JUCEApplication::main(juce::String&, juce::JUCEApplication*) + 605
45 com.cycling74.MaxMSP 0x002a31d9 juce::JUCEApplication::main(int, char**, juce::JUCEApplication*) + 125
46 com.cycling74.MaxMSP 0x001c994e main + 76
47 com.cycling74.MaxMSP 0x00002622 _start + 216
48 com.cycling74.MaxMSP 0x00002549 start + 41

#2 Updated by Pascal Baltazar about 10 years ago

  • Assignee set to Tim Place

#3 Updated by Nils Peters about 10 years ago

works for me.... no crashes

#4 Updated by Nils Peters about 10 years ago

update!: the same crash here if the DSP is on.

#5 Updated by Nils Peters about 10 years ago

  • Status changed from New to Resolved

rev. 5697 should fix this issue.
Pascal, please check as well.

#6 Updated by Pascal Baltazar about 10 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF