Bug #190

DSP flickr

Added by Nils Peters over 10 years ago. Updated almost 10 years ago.

Status:ClosedStart date:2009-07-12
Priority:HighDue date:
Assignee:Trond Lossius% Done:

0%

Category:-Estimated time:6.00 hours
Target version:0.5.1Spent time:0.70 hour
Branch: OS:

Description

Pascal wrote:

does anyone know what the "DSP flicker" bug comes from ?

i.e. :
open a patch with a jmod.control
turn audio on
open a patch with a jmod.control (while leaving audio on)
the audio goes crasy and turns on/off forever...?

Trond replied:

It has nothing to with Jamoma modular, dsp or multicore code as such,
but is a problem caused by how the adstaus~ object is used in some
moduls that under certain conditions cause conflicts that leads to
audio bein turned on and off repeatedly.

Please add a bug issue to the modular tracker and assign to
Me, and I'll see how it can be solved.

History

#1 Updated by Trond Lossius over 10 years ago

  • Target version set to 0.5

#2 Updated by Trond Lossius about 10 years ago

  • Estimated time set to 6.00

This bug is reproducible using only jmod.control as a module to turn on and of audio.

To test:

1) Open the below patch
2) Turn on audio,
3) Open one more instance while audio is running.

Repeat the above steps until the problem presents itself.

----------begin_max5_patcher----------
573.3ocyVFsjaBBEF9Z8ovgqsofZR112gdauoSmNDf3xtH3HXaxtylm8pfZL
azMFmLY1aD4.x4+7wAN9puGXiZGSCB9dvuB77d02yyZp1fWSeOPFdGQf01oA
jr+o17DHzMjgsy3Lq3Z1gVyxxLtTvL1OA0XLGaHOxko+ofQLNWtDBW.CCPHa
SxRamus.F76iKjpz79UhSs9rRGeAgZ84VkzHwYL6P+jUPwRb6Xt0vrOm47KP
ySkXAnyO0erl+hc3ZwTa8Me+5GgSDLarwGqXPFDONChisgcDz1D6HxZ3nPHd
.H.6bZK.dJSQWrkKLrhCKpzYkiGEFfvNfDdNZvEoMIHfr8+PQKEriClWvzLo
Aa3JYuXxFCvyhmYP0QR2n5bckWu9LtF8j3n8JzEx3RNG1OLqDNtzTC2sBE19
RS+5laZRXownjyEJtLwjtmS+X35QC7MXYJ3Vt0OuaZRZtbY92zr5yxEMrWnX
xv.H5C.vR24wD3j1igmCfXvLDqlnxYWsXQwVUF4zbSOayzkaD31kyQ1SDrCA
8tm8JCjHayJ3LJv8Ys91ewEcx4qjp0uPIt1Sks6rN7fVdoZeCvmnngq80nnK
V6af5bWp5Fxc6wxwzrPQdlQoE3TMoRBBqx6Qb6DABt78+4kkP01OcaPqJKHs
BtoDTvQ2QYZCWZEYu4r9j47HmRYx9mTx3zbUU4mtXdvThopHzDTTzcUQqlfh
pOOGftePBMUMEc+zzoHXXMEeeykNk.iKo4tyU04M++iuyTPp
-----------end_max5_patcher-----------

#3 Updated by Trond Lossius about 10 years ago

Trond Lossius wrote:

This bug is reproducible using only jmod.control as a module to turn on and of audio.

To test:

1) Open the below patch
2) Turn on audio,
3) Open one more instance while audio is running.

Repeat the above steps until the problem presents itself.

----------begin_max5_patcher----------
573.3ocyVFsjaBBEF9Z8ovgqsofZR112gdauoSmNDf3xtH3HXaxtylm8pfZL
azMFmLY1aD4.x4+7wAN9puGXiZGSCB9dvuB77d02yyZp1fWSeOPFdGQf01oA
jr+o17DHzMjgsy3Lq3Z1gVyxxLtTvL1OA0XLGaHOxko+ofQLNWtDBW.CCPHa
SxRamus.F76iKjpz79UhSs9rRGeAgZ84VkzHwYL6P+jUPwRb6Xt0vrOm47KP
ySkXAnyO0erl+hc3ZwTa8Me+5GgSDLarwGqXPFDONChisgcDz1D6HxZ3nPHd
.H.6bZK.dJSQWrkKLrhCKpzYkiGEFfvNfDdNZvEoMIHfr8+PQKEriClWvzLo
Aa3JYuXxFCvyhmYP0QR2n5bckWu9LtF8j3n8JzEx3RNG1OLqDNtzTC2sBE19
RS+5laZRXownjyEJtLwjtmS+X35QC7MXYJ3Vt0OuaZRZtbY92zr5yxEMrWnX
xv.H5C.vR24wD3j1igmCfXvLDqlnxYWsXQwVUF4zbSOayzkaD31kyQ1SDrCA
8tm8JCjHayJ3LJv8Ys91ewEcx4qjp0uPIt1Sks6rN7fVdoZeCvmnngq80nnK
V6af5bWp5Fxc6wxwzrPQdlQoE3TMoRBBqx6Qb6DABt78+4kkP01OcaPqJKHs
BtoDTvQ2QYZCWZEYu4r9j47HmRYx9mTx3zbUU4mtXdvThopHzDTTzcUQqlfh
pOOGftePBMUMEc+zzoHXXMEeeykNk.iKo4tyU04M++iuyTPp
-----------end_max5_patcher-----------

#4 Updated by Trond Lossius about 10 years ago

Deleting the jmod,control module, the problem goes away. I did not manage to reprocuce opening 50 instances of the below patch while audio was running:

----------begin_max5_patcher----------
515.3ocyVErbaBCD8L7UvnyDOR.1Ns+C8ZuzISFYzZGkAjXPho1IS72dfU.w
w1zhoNd5EVu6Jz6sOsrxu56QVo2BFRv2C9Ufm2q9ddXnl.ds9djb91zLtAWF
QA+Vu5YRnKkE1Zcg0RCruKrpJWpx.K9Jr1fEba5SR0lGKgTqCx4T5LZX.igl
j4ny2lQCd3iMRWYOdmjBDyZdbGi0g4Zsxp34.l5mPofq3c4b6gcWA3vkXjaT
7LRONMurQ9BltgLMQey2u4Q3HElUX8AkmUChGVChiwxNhhlXmhrjNnHDeFQf
1CZm.7btVLasLyBk6mUyyZfGTLHg8BR3oRCubSaCBIe2OzhpL3ijEkfATVtU
pUGTSXMPOodlfpNP6lvTXpQ8x63Z4ShSsWv9KcbImJ12OoFNox1Htqyzb7Gs
9MlqZSXk0pUSUTbchI8OG+mgKGrvWwUaHWyi9oMoIoc3xzmzr3+kAMvKBd54
Efn+f.L288XBcTmwzSEfXxDHqIUW.WLYYwHKibbt0CMimtQjqWOW5tzLXevA
yYuvBIBMKnS3Btu51NbMjLo53+G.VNMw+rdYzUkoc3zc6SPTOTBvXkJ7FgCV
Tb8ZX8q4IoP.pCO3xkhBc8zvVNLv.iKhRrQPI5siRrOA24ozQR4WMmVLVJcC
O4FAkhtoGb2OBFs7efQ0Nu4+Nntsr9F
-----------end_max5_patcher-----------

#5 Updated by Pascal Baltazar about 10 years ago

  • Priority changed from Normal to High

do we take a decision on this one ?
removing soft fades ?
postponing to 0.5.1 (not very good...)
could there be a solution for a newly opened jmod.control module to know another one is already present, and then act accordingly... (e.g. bypassing this swithcing thing...) ???
any ideas ?
I think we should do something about this before the release, it can be very frightening...

#6 Updated by Trond Lossius about 10 years ago

Hi,

I haven't gotten around to keep working on it yet. I'll first see if I can get it working in a such a way that smooth fade in/out can be preserved.

#7 Updated by Pascal Baltazar about 10 years ago

  • Status changed from New to Closed

this bug is gone with jmod.control... so long, and thanks for all the fish !

#8 Updated by Trond Lossius about 10 years ago

  • Status changed from Closed to Assigned

I am afraid not. We have the same issue in jmod.input~ and jcom.output~...

#9 Updated by Pascal Baltazar about 10 years ago

  • Target version changed from 0.5 to 0.5.1

I don't see any problem any more
the reason is because the problematic part of the patch isn't connected anymore..
we can re-introduce it later, for 0.5.1, for instance...

#10 Updated by Trond Lossius almost 10 years ago

  • Status changed from Assigned to Closed

Duplicates #193. Fixed in rev ed532a84 on master branch.

Also available in: Atom PDF