Bug #123

tt.filter crash when filtertype changed while DSP is running

Added by Tim Place over 10 years ago. Updated over 10 years ago.

Status:ClosedStart date:2009-05-28
Priority:UrgentDue date:
Assignee:Tim Place% Done:

0%

Category:-Spent time:0.20 hour
Target version:-
Branch: OS:

Description

What steps will reproduce the problem?
1. open jmod.sur.race~
2. start DSP
3. change filtertype from menu

crash:

Process: MaxMSP [35406]
Path: /Applications/Max5/MaxMSP.app/Contents/MacOS/MaxMSP
Identifier: com.cycling74.MaxMSP
Version: 5.0.6 (37312) (5.0.6)
Code Type: X86 (Native)
Parent Process: launchd [286]

Date/Time: 2009-01-22 09:35:59.682 +0100
OS Version: Mac OS X 10.5.6 (9G55)
Report Version: 6

Exception Type: EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000
Crashed Thread: 17

...

Thread 17 Crashed:
0 JamomaDSP 0x1614120f
TTLowpassLinkwitzRiley4::processAudio(TTAudioSignalArray*,
TTAudioSignalArray*) + 191
1 JamomaDSP 0x1612c6b8
TTAudioObject::process(TTAudioSignal&, TTAudioSignal&) + 104
2 org.jamoma.tt.filter~ 0x17197147 filter_perform(int*) + 253
3 com.cycling74.MaxAudioAPI 0x02b449d1 dspchain_tick + 93
4 com.cycling74.MaxAudioAPI 0x02b432d5 ad_process + 457
5 com.cycling74.ad_coreaudio 0x161f414d coreaudio_onedevice_ioproc + 254
6 ....audio_hijack_server.hermes 0x00d09444 AudioDeviceIOCallback + 79
7 com.apple.audio.CoreAudio 0x91be715b
HP_IOProc::Call(AudioTimeStamp const&, AudioTimeStamp const&,
AudioBufferList const*, AudioTimeStamp const&, AudioBufferList*) + 319
8 com.apple.audio.CoreAudio 0x91be6e4c
IOA_Device::CallIOProcs(AudioTimeStamp const&, AudioTimeStamp const&,
AudioTimeStamp const&) + 274
9 com.apple.audio.CoreAudio 0x91be6d28
HP_IOThread::PerformIO(AudioTimeStamp const&) + 1246
10 com.apple.audio.CoreAudio 0x91be5103 HP_IOThread::WorkLoop() + 1239
11 com.apple.audio.CoreAudio 0x91be4c27
HP_IOThread::ThreadEntry(HP_IOThread*) + 17
12 com.apple.audio.CoreAudio 0x91bd5464 CAPThread::Entry(CAPThread*) + 96
13 libSystem.B.dylib 0x914bb095 _pthread_start + 321
14 libSystem.B.dylib 0x914baf52 thread_start + 34

History

#1 Updated by Nils Peters over 10 years ago

  • Status changed from Assigned to Resolved

Since the latest changes in JamomaDSP, the crash reported above doesn't oocure anymore. (hurray!)

#2 Updated by Tim Place over 10 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF