Bug #1123

jcom.model.maxhelp need to be updated

Added by Trond Lossius almost 7 years ago. Updated almost 7 years ago.

Status:ClosedStart date:2012-04-11
Priority:NormalDue date:
Assignee:Théo de la Hogue% Done:

0%

Category:-Spent time:-
Target version:MVC for 0.6
Branch:0.6-alpha OS:

Description

In jcom.model.maxhelp one can send various messages to jcom.message by using the [s incoming] and [r incoming] objects. Some of these messages starts of with mymessage (without a slash) and others with /mymessage (with a slash). The message without a slash works fine, but the ones with the slash cause the following error message to be printed to the Max window:

/mymessage is an absolute address

It's hard for me to tell if this is a bug or assumed behavior, but anyway the help file need to be updated so that it serves to illustrate the use of jcom.model rather than exposing problems.

History

#1 Updated by Théo de la Hogue almost 7 years ago

  • Status changed from New to Closed

Hi Trond,
this not a bug but documentation is missing about this.
I've just added a red message to show thet the error is expected in the maxhelp.

but we need to make a specific tutorial (or any documentation) to explain the difference between absolute address (with a leading slash) and relative address (without leading slash). Relative address is a very powerfull feature that allow to edit some internal behaviours between models even if they are embedded inside a model.

Also available in: Atom PDF