Bug #1121

jcom.model @priority is broken

Added by Trond Lossius about 7 years ago. Updated about 7 years ago.

Status:ClosedStart date:2012-04-11
Priority:NormalDue date:
Assignee:Théo de la Hogue% Done:

0%

Category:-Spent time:-
Target version:MVC for 0.6
Branch:0.6-alpha OS:

Description

Steps to reproduce:

1) Open jcom.init.maxhelp
2) Look at the sequence of messages printed to the Max window.
3) Hit the init message box
4) Observe the sequence of messages printed to the Max window again.

To me there seem to be no relationship between the @priority attributes set in jcom.model objects of the sub patches and the sequence of prints in the Max window.

If this is correct, Theo, please create a new feature request for a test for this bug, and assign that to me, and I'll make an automated test for this issue.

Cheers,
Trond

History

#1 Updated by Théo de la Hogue about 7 years ago

  • Status changed from New to Closed

This is fixed with the f1d8696 commit.

I've fix the priority order but also I've mute the initialisation process of jcom.model which are into subpatcher : they now need to receive an initialisation message from an upper model to do their init. This avoid some unordered init due to unknown max object creation order.

Also available in: Atom PDF